closing tag is in template navbar
timefactors watches



TZ-UK Fundraiser
Results 1 to 8 of 8

Thread: Network/Router Problem

  1. #1

    Network/Router Problem

    Any insomniac network experts about who can help with this?

    Having problem setting up Outlook365 email to local mail server.

    Can connect wirelessly using hostname.com as server name – also works from phone. But using ethernet, hostname.com doesn't work and have to use local address (192.168.1.100) and this throws (understandable) SSL certificate error.

    Prefer to use ethernet on PC, any idea where problem is, router port forwarding?

  2. #2
    Grand Master markrlondon's Avatar
    Join Date
    Feb 2009
    Location
    London, England
    Posts
    21,982
    Blog Entries
    25
    Quote Originally Posted by Kingstepper View Post
    Any insomniac network experts about who can help with this?

    Having problem setting up Outlook365 email to local mail server.

    Can connect wirelessly using hostname.com as server name – also works from phone. But using ethernet, hostname.com doesn't work and have to use local address (192.168.1.100) and this throws (understandable) SSL certificate error.

    Prefer to use ethernet on PC, any idea where problem is, router port forwarding?
    It's not clear to me what exactly you are trying to achieve.

    Do you actually have a local mail server? What is the server software, as a matter of interest? Is the server fully accessible to the outside world? If so, via what protocols?

    Is your O365 client running locally on your PC or is it a web client?


    ** edit **

    And do you want to connect to your local mail server only via your local network (whether wireless or wired) or also from the outside world via the Internet?
    Last edited by markrlondon; 19th October 2019 at 04:32.

  3. #3

    Network/Router Problem

    Hello Mark, Yes, mail server is running on my Synology DiskStation (MailPlus package) over IMAP/STMP, is accessible anywhere (usually my phone over mobile data) and O365 is local.

    Essentially, problem is from PC I have to use ‘hostname.com’ in O365 server settings over wireless connection but ‘192.168.x.xxx’ if wired and I can’t see why they should be different - both through same router.

    Obviously, externally I use ‘hostname.com’ in server settings in email software and this works fine.

    Edit - had facts wrong way round and amended.
    Last edited by Kingstepper; 19th October 2019 at 09:22.

  4. #4
    Master
    Join Date
    Dec 2010
    Location
    NW Leics
    Posts
    5,493
    I'm not a Windows person at all, but it's worth checking whether the two different interfaces have different DNS servers assigned to them. In any case a hosts file setting should (I think) override DNS so you could hard code the address there.

    Output of ipconfig/all might provide a clue to what's going on.
    Last edited by monogroover; 19th October 2019 at 11:36.

  5. #5
    Master Xantiagib's Avatar
    Join Date
    Mar 2010
    Location
    Gibraltar
    Posts
    2,482
    hi +1 for host file setting

    the only quick way I can see around this SSL issue is to edit your hostfile (https://www.howtogeek.com/howto/2735...ur-hosts-file/)

    add the name.com of the server there with your local ethernet IP address

    then enter the server name as normal in outlook - this will force that hostname lookup to not go out on the internet and back in again to your network - it will just go straight there

  6. #6
    Grand Master markrlondon's Avatar
    Join Date
    Feb 2009
    Location
    London, England
    Posts
    21,982
    Blog Entries
    25
    Apologies for disappearing.

    Yes, it sounds like altering the HOSTS file on PCs on the LAN will solve the problem (to an extent). That is to say, add an entry for the external host name for the server pointing to the internal IP address. E.g. An entry like this: "192.168.1.20 external.server.com", where "192.168.1.20" is the internal LAN IP of the server.

    However, although this approach will work, it is is a bit clumsy. It has to be done on each internal device that might access the server and it doesn't work so well on mobile devices that might access the server both from the LAN and via external access.

    There are two solutions to this:

    (1) Run your own DNS server on the LAN. When any device connected to the LAN does a DNS lookup, it will get the local IP address for your server. This will save you having to alter the HOSTS file of any device connected to the LAN and it also works better with mobile devices. You'll probably need to run your own DHCP server too (instead of any DNS or DHCP servers currently running on your router). You could run DNS and DHCP on your Synology.

    (2) You can enable 'IP loopback' on your edge router. In this case, when this is enabled, when an internal LAN device tries to access an external world-addressable IP address that the router recognises as being NAT mapped to an internal address then it loops back the connection and allows it to proceed. Not all routers support IP loopback. It's useful when it's there. In fact I use IP loopback on my own router for LAN access to my mail server using hostnames that resolve to external IP addresses.

    If you can do IP loopback then this is easiest as it requires no maintenance. That said, your own DNS and DHCP servers aren't difficult to maintain.

  7. #7
    Thanks everyone for suggestions. I'll look at a hosts file.

    (Mention of Outlook was slight red herring, can't connect to server at all over LAN using hostname.com, only by WiFi.)

  8. #8
    Grand Master markrlondon's Avatar
    Join Date
    Feb 2009
    Location
    London, England
    Posts
    21,982
    Blog Entries
    25
    Quote Originally Posted by Kingstepper View Post
    can't connect to server at all over LAN using hostname.com, only by WiFi.
    As above, HOSTS will do the job on a per-device basis. But better, more flexible, solutions are as I suggested, either your own local DNS and DHCP servers or, frankly easiest of all, enabling IP loopback on your router (good ones support this).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •