closing tag is in template navbar
timefactors watches



TZ-UK Fundraiser
Results 1 to 19 of 19

Thread: Help releasing reserved memory please

  1. #1
    Administrator swanbourne's Avatar
    Join Date
    Oct 2002
    Location
    Sheffield, England
    Posts
    46,432

    Help releasing reserved memory please

    I have a Dell i7 computer with 16GB RAM and an ASUS GTX1050Ti 4GB graphics card. The problem is, Windows is reserving 8GB of memory for "hardware". I can only imagine that this is the graphics card because I don't have any other peripherals installed. The BIOS is an old BIOS but there are no updates.

    There is no Memory Map function within BIOS to disable the reserved memory and allow Windows to have full access to the installed memory.

    Is there any utility that would allow this or some command line within Windows? I'm running Win 10 64 Pro and I realise that this machine would have been intended for use with Win 7.

    Eddie
    Whole chunks of my life come under the heading "it seemed like a good idea at the time".

  2. #2
    Master amnesia's Avatar
    Join Date
    Mar 2011
    Location
    Peterborough
    Posts
    2,526
    Blog Entries
    1
    installubuntu.exe ?

    Sorry, not much help, but I now have zero time for Windows 10 and Microsoft's perpetual 'test it in production' ideology.
    Recent updates have caused hours of effort to resolve f##ked-up installs. Now that I've got Office 365 (through my work's HUP deal) I don't need Windows anymore, which is great.

    I would have thought that your gfx card would have it's own memory - you haven't got integrated graphics consuming resources, have you ?
    This might help... https://forums.tomshardware.com/thre...emory.3339698/

  3. #3
    Master sish101's Avatar
    Join Date
    Jul 2017
    Location
    County Durham
    Posts
    1,481
    Quote Originally Posted by swanbourne View Post
    I have a Dell i7 computer with 16GB RAM and an ASUS GTX1050Ti 4GB graphics card. The problem is, Windows is reserving 8GB of memory for "hardware". I can only imagine that this is the graphics card because I don't have any other peripherals installed. The BIOS is an old BIOS but there are no updates.

    There is no Memory Map function within BIOS to disable the reserved memory and allow Windows to have full access to the installed memory.

    Is there any utility that would allow this or some command line within Windows? I'm running Win 10 64 Pro and I realise that this machine would have been intended for use with Win 7.

    Eddie
    Can you provide the model (or service tag)?

    Sent through the ether by diddling with radio waves

  4. #4
    Craftsman
    Join Date
    Nov 2012
    Location
    london
    Posts
    610
    What To Try

    There are several additional situations that could cause the usable RAM to be less than expected. These issues and possible solutions are listed here:

    Check the system configuration settings

    This problem may occur because the Maximum memory option is selected incorrectly. To fix this, follow these steps:

    Click Startwindows icon, type msconfig in the Search programs and files box, and then click msconfig in the Programs list.
    In the System Configuration window, click Advanced options on the Boot tab.
    Click to clear the Maximum memory check box, and then click OK.
    Restart the computer.

    Check BIOS settings

    The problem may occur because some BIOS settings are incorrect.

    Enable the memory remapping feature

    Check the BIOS settings to see whether the memory remapping feature is enabled. Memory remapping gives Windows access to more memory. You can enable the memory remapping feature in the BIOS by booting to the system setup. See the User's Guide for your computer for instructions on how to boot to system setup on your computer. The name for the memory remapping feature may be different for different hardware vendors. This can be listed as memory remapping, memory extension, or something similar. Be aware that your computer may not support the memory remapping feature.

    Check possible issues with the physical RAM

    The problem may occur because there are issues with the physical RAM installed.
    Check whether you have bad memory modules

    To check whether you are experiencing this issue, turn off the computer, unplug the computer, and then swap the order of the memory.
    Make sure that the memory arrangement is correct

    Refer to the User's Guide of the computer to determine in what order the memory modules should be inserted into the memory slots. The system may require you to use specific slots when you are not using all the available slots. For example, the computer has four slots available. But you may have to use slot 1 and slot 3 if you want to use only two memory modules.

  5. #5
    Administrator swanbourne's Avatar
    Join Date
    Oct 2002
    Location
    Sheffield, England
    Posts
    46,432
    I've tried everything already mentioned except installing linux. There is no memory mapping function in the BIOS and there are no updates to the installed BIOS.

    The computer is Dell Vostro 430.

    The graphics card is an ASUS GTX1050Ti with 4GB of its own memory.

    MSconfig reports 16GB of memory with 8GB reserved for hardware, I wouldn't have thought it would report 16GB if any of the 4 DIMMs were faulty. All 4 memory slots are being used.

    Eddie
    Whole chunks of my life come under the heading "it seemed like a good idea at the time".

  6. #6
    Grand Master oldoakknives's Avatar
    Join Date
    Sep 2012
    Location
    Brussel land.
    Posts
    13,220
    Courage is being scared to death but saddling up anyway.

  7. #7
    Master IAmATeaf's Avatar
    Join Date
    Nov 2011
    Location
    NW London
    Posts
    3,957
    Reading the posts in the link seems to suggest bad memory.

  8. #8
    Long shot but try taking some memory out - if it's not there it can't reserve it.

    Then replace it.

  9. #9
    Craftsman
    Join Date
    Jan 2019
    Location
    Ireland
    Posts
    323
    Can you use task manager or perfmon to see what process is consuming the most memory, then disable that process?

    I find windows 10 fantastic, and the problem is generally with some software installed on the machine, or dodgy drivers written in haste by a hardware manufacturer.

    Getting an idea of what process is consuming the memory is the first step.

  10. #10
    Quote Originally Posted by Wilson_smyth View Post
    I find windows 10 fantastic, and the problem is generally with some software installed on the machine, or dodgy drivers written in haste by a hardware manufacturer.
    Agree with this, very stable and nothing like Windows of old.

  11. #11
    Grand Master hogthrob's Avatar
    Join Date
    Feb 2007
    Location
    Essex, UK
    Posts
    12,010
    Quote Originally Posted by Kingstepper View Post
    Long shot but try taking some memory out - if it's not there it can't reserve it.

    Then replace it.
    Take one pair of DIMMS out, and check it works OK with 8GB. Assuming that's OK, try the same with the other DIMMS.

    Have you made any hardware changes to the PC recently?

  12. #12
    Craftsman
    Join Date
    Jan 2019
    Location
    Ireland
    Posts
    323
    Quote Originally Posted by hogthrob View Post
    Take one pair of DIMMS out, and check it works OK with 8GB. Assuming that's OK, try the same with the other DIMMS.

    Have you made any hardware changes to the PC recently?
    Thats step 2 or 3. try the easy stuff first, look at task manager and see what process is consuming all the memory. then decide the next step.

  13. #13
    Administrator swanbourne's Avatar
    Join Date
    Oct 2002
    Location
    Sheffield, England
    Posts
    46,432
    I've run the Windows Memory Test tool and that didn't find any problems with memory. Nothing's hogging the memory, it's "reserved" (not used)

    Eddie
    Whole chunks of my life come under the heading "it seemed like a good idea at the time".

  14. #14
    Master studly's Avatar
    Join Date
    Aug 2011
    Location
    Scotland
    Posts
    2,028
    Buy more ram? Another 16gb if it has two slots or a 32gb if not.

    Or remove the graphics card if you don't use it, although it might not be that.

    Take out the ram and clean the slots.

    It could also be a faulty motherboard.
    Last edited by studly; 20th September 2019 at 11:52.

  15. #15
    Grand Master Chris_in_the_UK's Avatar
    Join Date
    Nov 2004
    Location
    Norf Yorks
    Posts
    35,810
    When you look long into an abyss, the abyss looks long into you.........

  16. #16
    Administrator swanbourne's Avatar
    Join Date
    Oct 2002
    Location
    Sheffield, England
    Posts
    46,432
    Quote Originally Posted by Chris_in_the_UK View Post
    I've gone through this, the BIOS doesn't have a memory map section and it doesn't have the facility to turn off iGPU. I've had the DIMMs out and made sure the connectors are clean, although this was probably a waste of time given that Windows Memory Test tool gave memory the OK.

    Eddie
    Whole chunks of my life come under the heading "it seemed like a good idea at the time".

  17. #17
    Master IAmATeaf's Avatar
    Join Date
    Nov 2011
    Location
    NW London
    Posts
    3,957
    Try each stick one at a time, make sure Windows boots up with each stick in turn.

  18. #18
    Grand Master Chris_in_the_UK's Avatar
    Join Date
    Nov 2004
    Location
    Norf Yorks
    Posts
    35,810
    Quote Originally Posted by swanbourne View Post
    I've gone through this, the BIOS doesn't have a memory map section and it doesn't have the facility to turn off iGPU. I've had the DIMMs out and made sure the connectors are clean, although this was probably a waste of time given that Windows Memory Test tool gave memory the OK.

    Eddie
    I suspect this is old hardware 'v' new software then Eddie.

    Maybe time for an upgrade?
    When you look long into an abyss, the abyss looks long into you.........

  19. #19
    Grand Master oldoakknives's Avatar
    Join Date
    Sep 2012
    Location
    Brussel land.
    Posts
    13,220
    Quote Originally Posted by swanbourne View Post
    I've gone through this, the BIOS doesn't have a memory map section and it doesn't have the facility to turn off iGPU. I've had the DIMMs out and made sure the connectors are clean, although this was probably a waste of time given that Windows Memory Test tool gave memory the OK.

    Eddie
    Maybe time to upgrade.........



    Simple to get used to, for the 'older' gentleman..............(like me for example )
    Courage is being scared to death but saddling up anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •